Welcome to Nick's Random Musings

Of course I don't know what I'm doing, what fun would that be?


Using OpenWRT as a Router for a CenturyLink modem


meta
Nick Gully, Denver
Using an OpenWRT 21.02 device on CenturyLink fiber internet.
This is a small J1900 Celeron device with four gigabit ethernet ports.
The Eth0,2,3 are the local network.
Eth1 connects to the fiber modem.
The VLAN is 201 for CenturyLink

config interface 'loopback'
    option device 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd39:05db:f787::/48'

config device
    option name 'br-lan'
    option type 'bridge'
    list ports 'eth0'
    list ports 'eth2'
    list ports 'eth3'
    option vlan_filtering '1'

config interface 'lan'
    option device 'br-lan'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

config interface 'wan'
    option password 'PASSWORD'
    option ipv6 'auto'
    option device 'eth1.201'
    option proto 'pppoe'
    option username 'USERNAME'

config device
    option name 'eth1.201'
    option type '8021q'
    option ifname 'eth1'
    option vid '201'
    option macaddr 'XX:XX:XX:XX:XX:XX'

Origin Story


meta
Nick Gully, Denver

Influencers, like Superheroes, need an origin story.

Gully.org at 20 years


meta
Nick Gully, Denver

Creation Date: 2002-06-19T16:43:03Z

That's alot of spam recieved, nginx / apache reconfigurations, and apt-get updates. Being a small fish in a big pool ain't easy, but it has been educational.

The STL C++ Vampire


meta
Nick Gully, Denver

Count If

V begin, V end, Ah Ah Ah.

Healthy Surprise


meta
Nick Gully, Denver

Fill the piƱata with Brussel sprouts, broccoli florets, carrots and snap peas.

« Older Posts Newer Posts »